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User's Manual

for the

ERG Desktop Viewer (ERGVIEW)

Version 4.3

Indications For Use:

The HMsERG/ERG system is an electro-diagnostic device used to generate photic 

evoked signals, to quantify and display the electrical signals generated by the retinal 

response  and  the  visual  nervous  system.   The  device  displays  digitized 

electroretinogram  (ERG)  and  visual  evoked  potential  (VEP)  signals.   These 

functions  are  controlled  and  interpreted  by trained  medical  professionals.   This 

device  is intended for prescription use.
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The ERGVIEW program  is...

A product of 

Ocuscience LLC.

8609 Jarboe St.

Kansas City, MO 64114

(816)529-5712

fax: (866)904-2589
www.ocuscience.us

For service contact:

Linscan Systems, Inc.

202 W. Ninth St., Ste 301

Rolla, MO 65402-1217

573-364-6631

800-533-7226

www.linscan.com

The Ocuscience Desktop ERG Viewer Application (ERGVIEW) is designed to display 

and analyze ERG test data files that were recorded by  the Handheld Multi-species 

ElectroRetinoGraph (HMsERG) Unit.
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Main (or Start-up) Window

The ERGVIEW Main window is the window displayed when the ERGVIEW program in initialized. 

It acts as a gateway to the Session window, and the Test Locator window.  It is also possible to  

examine ERG's with Comparison graphs using only the Main window and drag and drop operations. 
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Starting the ERGVIEW program

Start the ERGVIEW program by double clicking on the desktop icon (similar to the 

one to the left), or by selecting Start > Programs > Ocuscience> 

ERGVIEW4030 > ERGVIEW.EXE, or by double clicking on an ERG test file 

(‘.tst’ file). Any of these  methods will bring up the main, or start-up, window as 

shown above.  Double clicking on a test file will also open a session window.  

From the Main window test files and patient information may be accessed by using 

the buttons along the bottom of the window or by using the drop down menus.

Ending the ERGVIEW program

The program can be terminated correctly in three ways, by clicking on the close button at the upper 

right corner of the Main window, by choosing the File > Exit menu, and by right clicking on the 

ERGVIEW taskbar icon and selecting 'Close'.

If any windows besides the Main window are open you will be asked if you want to end the program; 

otherwise, the Main window will close immediately.
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Main window control reference:

Buttons:

PC SESSION button

Clicking this button will open a file selection dialog.  The user may need to change this directory 

to a location where HMsERG data files of interest are stored (e.g. the desktop, or a directory 

where test files have been previously stored on the PC) and then, choose either an ERG test  file 

or a special session file.  If the test file selected is part of a session or of multiple runs of a single 

test, not only the selected file but all the associated files will be displayed in a session analyzer 

window - i.e. all files in the folder with the same patient number and session number will be 

placed in the session analyzer window.  Multi selection of files is allowed.  This means that the 

user may select files using the shift key for a range of files or the control key for individual files. 

If multi select is used (and more than one file is selected) only those files selected will be put into 

the session window. 

This button is equivalent to the File > Open Session from PC menu selection.

UNIT SESSION button

Before using this selection, the HMsERG must be connected to the PC as per the Appendix.. 

When this button is pressed the USB connection with the unit will be checked and then a  file 
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selection window will appear. This selection window will show the directory structure of the 

compact flash card within the HMsERG unit.  Left click on a directory to open it and then left 

click on a test file to load it and the session files associated with it into a session window. 

This button is equivalent to the File > Open Session from Unit menu selection.

TEST LOCATOR button

This selection will open a Test Locator window.  The test locator window is used to aid in 

searching for ERGs test files stored on the PC.

This button is equivalent to the File > Open Test Locator menu selection.
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Menus:

-File 

--Open Session From PC

This selection performs the same function as does the "PC 

SESSION" button.

--Open Session From Unit

This operation of this selection is the same as that of the the 

"UNIT SESSION" button.

--Open Test Locator Panel

This selection is the same as using the "TEST LOCATOR" button.

--Open a special session

Opens a file select dialog for choosing a special session file.

-Edit

--Change Font

Allows the program font selection to be changed.  All 

Session, Test Locator, and Graph windows opened after the 

font change will be affected.

--Open Comparison graph

Opens a blank Comparison graph.  Test, xy, and csv files 

may be dragged and dropped onto a Comparison graph.

-Help

--Open User Manual

Opens the (pdf formatted) user manual.
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Drag and Drop operations:

Certain files can be dragged from a windows file list to the Main window of the ERGVIEW 

program.  In general, what happens will be similar to what would happen if the file was selected 

by means of a menu or button.

Multiple files may be selected at the same time.  In the case of test or special session files, one 

combined Session window will be created.  For graph files ('xy', 'csv') they will all be placed on 

the same comparison graph.

HMsERG test files (extension 'tst')

Dragging and dropping a test file onto the Opening window will open a session the same as if 

that file was selected after the PC SESSION button was pressed.

Special session files (extension 's_f')

Dragging a special session file to the Main window will open the tests referenced by that file.

x-y formatted files (extension 'xy')

If a global comparison graph ( Edit > Open Comparison Graph ) exists, the xy data will be added 

to the current Comparison graph, if no graph is currently open, one will be created.

csv formatted files (extension 'csv')

If a global comparison graph ( Edit > Open Comparison Graph ) exists, the csv data will be added 

to the current Comparison graph, if no graph is currently open, one will be created.
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Session Analyzer Window

 

During normal use either individual ERG tests or an automatic series of tests collectively called 

a   session are run on the  HMsERG.   Sessions  are designed to comply with recommended 

protocols,  such as  the  ISCEV protocol,  the  Dog Diag protocol,  and the  Short  protocol.   A 

Session Window is created by either of the  View Session buttons on the opening screen, by 

way of another  Session Window, or from a  Test Locator Window.  The Session Window 

displays thumbnail representations of all the ERG’s in a session.  From the Session Window, 

test results may be investigated by right clicking on a thumbnail and selecting an analysis tool 

from the pop-up menu.  

The number of thumbnails displayed on a session window at one time is determined by the size 

of the screen it is displayed on and the currently selected font. The slider control may be used to 

scroll any hidden thumbnails into view.

The group of tests in a  Session Window may be modified by selecting  File > Add to this  
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Session  from  the  menu  bar or  by  “cutting”  and   “pasting”  as  described  below  under 

Thumbnail editing below.  Multiple session windows may be opened by selecting File > Load 
Another Session.  

- Changing the thumbnails on a Session window.

Thumbnails may be added to or removed from a Session window by using the {right click} > Edit  
Test  menu.  Cut, copy and paste operations may be performed within a single session or between 

thumbnails located on separate session windows.  ERGs may also be copied from a  Test Locator 

Window and placed on a Session window.

1

11  ERG files from the PC and those read over the USB from the HMsERG must not be mixed using the editing commands.
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Session window Menus.

File > Add to this Session
Opens up a disk file dialog and allows 

selection of ERG test files that will be 

appended to the current session window.

File > Open Another Session
Opens up a disk file dialog and allows 

selection of files that will be displayed in 

their own session window.

File > Open a Test Locator Window
Opens up a test locator window pre-

loaded with the test id of the first thumbnail in the session. 

File > Load a special session
This option allows the user to load a previously saved special session.  The default file path 

for special sessions is independent of the default file path for regular sessions so that special 

sessions may be saved together in their own directory for later access.

File >Save as a special session
This option allows the user to save a reference to the tests of the current session window under 

a name of his choosing. 

File > Print
Opens up a print dialog and prints all session thumbnails at six per page plus the session 

summary information.

File > Close
Same as clicking the ‘X’ close button at the upper right of the session window.

--------------------------

Edit > Copy BMP
Copies the user area of the session window to the windows 

clipboard in bitmap format.  It can then be pasted into a paint 

or word processing program.

Edit > Sort By File Time
When a standard session is opened it is sorted by the file 

names used for each individual test.  This is usually fine and 
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is automatically in chronological order.  However, if a special session is opened or if 

thumbnails have been moved around using the thumbnail 'Edit Session' menu the 

thumbnails may not be ordered by time.  This selection will restore the time ordering of the 

thumbnails as determined by the time the files were recorded.  File times are accurate only 

to the nearest second.

--------------------------

View > Summary
Opens up a summary window.

--------------------------

Filter > 60Hz Filtering
Filter > 50Hz Filtering
Filter > Spike Filtering
Filter> Low Pass Filtering

Enables software filtering of all thumbnails in 

a session at once.  Filtering selected for a 

specific thumbnail interacts with this selection 

in that whichever selection is made last 

(session or thumbnail) will be the controlling 

selection.  .

Filter> Set Low Pass Frequency
Opens up a window - as shown below - to allow the low pass cutoff frequency to be set.  The 

value set here will be applied to all thumbnails in the session.
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Thumbnail Panels

Each ERG test is displayed on the Session Window in the form of a “thumbnail” panel with 

three main sections.  The left section shows the relevant session/test information to identify this 

specific ERG.  The center section is a graphical representation of the ERG.  The area to the right  

of the graph displays current values for a and b waves along with filtering information.  The line 

‘–auto a/b’ is displayed if the a and b-wave values are being calculated automatically by the 

program.  If a and b-wave calculation is automatic the values will be recalculated whenever any 

filtering conditions are changed.

Each Thumbnail, by means of a popup menu,  also provides a gateway to further analysis of that 

specific ERG test data.

To access the gateway right click on the desired ERG recording thumbnail.  A popup menu, as  

shown below, will allow the user to:

1) copy the test data to a Measurement Graph, perform an FFT analysis, analyze the data to 

show the oscillatory potentials, open a Comparison Graph, or copy the ERG trace to the 

trace clipboard, 

2) Apply a software filter to this particular ERG.

3) copy and paste thumbnails between (or within) session windows. 
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4) retrieve information about where the test data came from, and provide the capability to add 

notes and identification information about this particular ERG.

Selecting the Test source info item opens a window displaying the serial number of the unit that 

recorded the test, the compact flash card id it was originally recorded on, the version of the 

software on the unit, the path on the PC to where the test file is located.  The State window 

also allows the user to enter notes about this specific ERG and assign it a User Id that can be 

searched for using the Test Locator window.
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Thumbnail Menus

{right click} > Copy Test Data To > Trace Clipboard
Puts the ERG data onto the trace clipboard allowing it 

to be pasted onto a Comparison graph.

{right click} > Copy Test Data To > Measurement Graph
Opens up a Measurement graph showing the selected 

ERG.

{right click} > Copy Test Data To > Osc Potentials Graph
Opens up an oscillatory potential graph showing the results of filtering of the selected ERG. 

The default range is a band pass filter from 100 to 300 Hertz.

{right click} > Copy Test Data To > Comparison Graph
Opens up a comparison graph showing the selected ERG.

{right click} > Copy Test Data To > FFT Graph
Opens up an FFT graph showing the Fourier coefficient magnitudes for the selected ERG.

{right click} > Copy Test Data To > Text file (csv,xy)
Allows for saving the ERG information into a text file of x-y values in either 'csv' or 'xy' 

format that can be read into a spreadsheet program.

--------------------------
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{right click} > Filter > Show Sample Selection Window

This menu selection displays a samples window for the thumbnail.  It is only available  
if  the thumbnail  has samples associated with  it.   See the WORKING WITH DATA  
SAMPLES section.

{right click} > Filter > 60 Hz
{right click} > Filter > 50 Hz
{right click} > Filter > Spikes
[right click]> Filter > Low Pass
[right click]> Filter > Set Low Pass Frequency

These  five  selections  call  up  and  set  appropriate 

software filters for eliminating power line or hardware 

noise  on  the  ERG  waveform.   The  low  pass  filter 

defaults  to  a  150Hz  cutoff  point  but  the  cutoff 

frequency can be changed by selecting ‘Set Low Pass Frequency’; this will bring up a window 

for setting the low pass frequency cutoff.

In  the  low  pass  cutoff  window,  enter  the  desired  cutoff  frequency  in  hertz  and  select  the 

‘Update’ button to see the effect on the thumbnail graph (low pass filtering is automatically 

turned on if necessary).  The ‘Revert’ button will reset the filter frequency value to what it was 

when the window was opened.  The ‘Close’ button hides the window

The new value for the low frequency cutoff will be 

stored with the thumbnail state information when the 

thumbnail closes.

--------------------------

{right click} > Edit Session > Cut

Removes the ERG from the session and sets it up 

to be “pasted” into another location.

{right click} > Edit Session > Copy
Sets up the ERG so a copy of it can be “pasted” 

into another location.
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{right click} > Edit Session > Paste > Before This Test
Inserts the last ERG to be “cut” or “copied” before the selected thumbnail.

{right click} > Edit Session > Paste > After This Test
Inserts the last ERG to be “cut” or “copied” after the selected thumbnail.

--------------------------

{right click} > Test Source Info

Opens up a window displaying the serial number of the 

HMsERG unit the test was run on, the compact flash card 

id, the path on the PC where the test was stored, a User Id, 

and Notes.  The User Id and Notes can be entered by the 

user and will be saved in the state file for the thumbnail.

The User ID entered here can be used on a test locator 

window for finding specific tests. 

14SEP2012 19

Illustration 20: Test Source Info or 

'State' Window



Summary Window

ERGVIEW

Summary window

The summary window is called up from a session window via session menu bar View > 
Summary.  It displays data on all tests that are currently on the session window (visible or 

otherwise).  The summary window provides a quick view of most of the ERG testing 

parameters and can be used to plot test parameter trends.

There are two main areas of a summary window; the heading area and the data area.  The 

heading area contains the column titles, the data area contains the values.  The distinction 

becomes important for selecting and plotting values from the summary window.

When there are more rows in the session window than can be displayed on the summary 

window, the menu bar (to the right of “Plot”) will display options to scroll up and scroll down. 

A-wave and b-wave values on the summary window are initially determined automatically by 

ERGVIEW.  When a measurement graph is opened these a and b wave points are displayed 

and may be modified by the user.  As the a and b wave values on the measurement graph are 

changed the corresponding summary window values are also changed.. 

- Summary window columns

number

The position a specific data row occupies in the session window.

delta time

The time from the ERG occupying position 1 as determined by the file time associated with the 

test data.  Delta time format is <days>|<hours>:<minutes>:<seconds>.

test

The HMsERG assigned test number for the row.

eti

The elapsed time from the start of a session till test data is stored.

flash intensity
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The flash amplitude used for the test.

a-wave amplitude, a-wave implicit time, b-wave amplitude, b-wave implicit time

Parameters measured from the specific test data.  The values can be examined visually on a 

Measurement Graph.

b/a ratio

The b-wave amplitude divided by the a-wave amplitude.

- Selecting data from a summary window for graphing.

The numeric values displayed on a summary sheet may be used as x and y values for display on a 

comparison graph.  The following steps are recommended:

1) Before calling up the summary window, edit it’s parent session window so that only the 

thumbnails for the ERGs desired are present.

2) Open a summary window. 

3) Sort the column to be used for the ‘x’ coordinates by left clicking in the header area for that 

column.  This may be any column except the test name column.

4) Select the column just sorted for ‘x’ values by right clicking in the header area for that column 

and selecting “X value” from the pop-up menu.  The column data values will be colored red.

5) Select the desired ‘y’ column by right clicking in the header area for that column and selecting 

“Y value” from the pop-up menu. The column data values will be colored green.

6) Plot the selected values with Plot > Selected Points from the menu bar.

The data values can be saved for use in a spreadsheet program from the comparison graph.  

Alternatively, values from the summary window can be selected individually as x or y values 

by left clicking with the cursor on an x value and right clicking on the corresponding y value (x 

values become red and y values become green).  The data points thus selected can be plotted (in 

the order selected) as described in step 6 above  by selecting Plot > Selected Points.

Multiple sets of data may be plotted by creating the first plot, selecting Plot > Reset, then 

creating the next plot. 

 

If desired, all summary sheet data may be saved in text format by selecting (summary window 

menu bar) Edit > Save as Text.  The text data can then be loaded into a spreadsheet program 

(Excel, Quattro Pro, etc.) for analysis.
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Summary window Menus

File > Print
This is the same as the menu bar selection on the session window.  If columns of the 

summary window have been sorted, the printout will reflect the sorted order.

--------------------------

Edit > Save as Text

Opens a dialog for file selection and then outputs the contents of the summary page as tab-

separated columns and newline separated rows. This format is accepted by most spreadsheet 

programs.

--------------------------

Plot > Selected Points

After x and y values have been selected from the summary window, then Plot>Selected 

Points will graph the values on a comparison graph. 

Plot > Reset

Clears the selected point buffer so that another set of points may be chosen.

--------------------------

{left click in heading area}

Sorts (rearranges the rows) to put that column in ascending order (smallest to largest).  The 

summary window data rows are moved around till the sort criteria is met.

--------------------------

{right click in heading area} X value

Selects the entire column in order (top to bottom) as x values for plotting.

{right click in heading area} Yvalue

Selects the entire column as y values for plotting.

When  File > Print is selected on either a session window or a summary window a session 

printout is produced.  This printout will contain all the tests of the session, presented in the same 
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way as  the  thumbnails  on  a  session  window and with  the  same ordering,  followed by the 

contents of the summary window.  Each page will have a heading showing the test id of the first 

test on the session and the name of the session - similar to the first line of the thumbnail text.  At 

the bottom of the page will be the page number, the ERGVIEW version,  and the date of the  

printout.
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Special Sessions

Special sessions are composed of the contents of any session window that has been given a 

special session name.  Usually it is a session in which the thumbnails (= ERG's) have been 

reordered, deleted, or inserted.  They allow the user to create a session of his own choosing 

containing the ERG's relevant to a certain context.  For example, ERG's for a certain patient 

recorded at different times, or ERG's of different patients for comparison. 

The default directory for special sessions is separate from that of regular sessions.  This allows 

the user to save his special session name files in a single directory, if desired, separate from the 

directory where the ERG's of that special session are stored.

Along with the test locator window, special sessions allow the user to find the ERG's she wants.

Logical relationship between session and thumbnail file menus.

If a specific filter (60 Hz, 50 Hz, Spike, Low Pass) is selected in every thumbnail in a session then 

that filter will be marked in the session filter menu.

If every thumbnail has it's low pass cutoff set to the same frequency, it is that frequency that will 

show up when the session Filter > Set Low Pass Frequency is opened; otherwise the session low pass 

frequency will be 150 Hz.

When the session low pass frequency is set, it will be set and low pass filtering will be turned on for 

every thumbnail of that session. 

Each thumbnail can have filter values set that will be independent of the values of all other 

thumbnails until those same filter values are set using the session filter menu.
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Comparison Graph

The Comparison graph is used for displaying one or more waveforms.  ERG's can be visually 

compared, measured, and then saved in either xy or csv format for later viewing.  The data 

points  may be examined at  varying magnifications  and markers may be placed for making 

measurements.  If there are data sample files associated with a test waveform the Show Samples 

button will be visible and can be used to open a Samples window.  
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- Major parts of the Comparison graph.

The white box on the left below the graph area is a list of the traces currently present on the 

graph.  Three traces can be seen at a time in the list, if the graph has more than three, a scroll 

bar will show at the right of the tracelist. 

In the center is the 'attributes panel'.  This panel shows the characteristics of the trace that is 

currently highlighted in the trace list.  

In the lower left corner you can see the underlined phrases for changing the x and y gains.  Each 

gain change is by a factor of 2 and is accomplished by left clicking on the appropriate phrase. 

Selecting Graph > Reset Graph Scaling will put the graph back to its original scaling.

The status bar at the very bottom monitors the position of the cursor 

when it is in the graph area.

The TCopy and TPaste (Trace Copy/Trace Paste) buttons are for 

convenience.  Copy is specific to the selected trace, paste brings 

into the graph the latest contents of the trace clipboard.
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- Markers

Comparison graphs allow for manual measurements using markers like the Measurement graph 

does.  The popup menu following a right click includes entries to set marker 1 or marker 2.  If 

selected, the appropriate marker will be set to the position of the windows cursor when the 

mouse was right clicked.  The procedure is, set the windows cursor on a spot (time and voltage 

are reflected in the status display), right click and select a marker.  Marker positions and their 

differences are listed below the trace list.

Markers can be set by right clicking in the graph area and selecting either Marker one or Marker 

two.  

Markers are indicated on the graph by gray vertical and horizontal lines.  When markers have 

been placed their position(s) will be displayed below the trace list - Marker 1 on the first line, 

Marker 2 on the second line and, if both markers are set,  the change in time and voltage on a 

third line.

Either marker may be reset to a new position any number of times.  Markers may be hidden by 

unchecking a selection under the Graph menu.
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- Attributes panel

The attributes panel displays and allows modification of the attributes of the trace being 

highlighted in the trace list.

-Buttons:

TCopy
Copies the selected trace to the trace clipboard.

Show Samples
This button is only visible is there are data samples associated with the current trace. 

It opens the sample window for this trace/test.  See the WORKING WITH DATA 

SAMPLES section.

-Check Boxes:

Show trace
Shows or hides the trace.  This selection is useful to hide a trace if the graph is too 

cluttered or if one trace is being obscured.

Use for scaling
Normally the graph scales itself so that all traces are visible.  This means that a large 

amplitude trace could shrink a small amplitude trace to the point where it is hard to 

make out.  When this happens, deselecting the Use for scaling attribute of the large 

amplitude trace will allow the graph to scale up the small amplitude trace.

Spikes, 60Hz, 50Hz, Low Pass
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These four selections turn on or off the corresponding filtering.

-Edit Control:

LP Freq ';'
This is the value used for the low pass frequency cutoff.  Entering a semicolon after a 

value is displayed in the window lets the program know that a new value has been 

requested.  If the Low Pass check box is selected, the corresponding trace should 

update when the semicolon is entered.

-Selection Boxes:

Right clicking on any of the selection boxes will bring up a pop-up menu.

Symbol selection

Symbol (none, plus, diamond, square, circle)

Chooses the symbol placed at each 'separation distance' from 

time 0.0.

Size (3mm, 4mm, 5mm, 6mm, 7mm, 8mm)

This is the distance from the center of a symbol to it's sides and 

it's top and bottom on the screen.

Separation (5mS, 10mS, 20mS, 30mS)

Symbols are placed at time 0.0 and at each separation distance from there.

Color (Red, Yellow, Green, Blue, Violet, Black, Gray )

Selects the color of the symbol.

Trace line selection

Fill (None, Solid, Dash-2, Dash-5, Dash-10)

Selects what the program uses to fill in between the actual data points.  Default is 

'Solid'.

Width (0.5mm, 1.0mm, 1.5mm, 2.0mm, 2.5mm)

This selection determines the width of the line used to draw the trace and the symbols.

Color (Red, Yellow, Green, Blue, Violet, Black, Gray, White)

Selects the trace color.
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Actions available on the comparison graph.

Left clicking on a point in the graph area will move that point to the center of the graph.

Right clicking on a point in the graph opens up a menu that allows modification of the graph 

and it’s traces on an individual basis.

The TCOPY and TPASTE buttons provide an alternate way to perform the trace copy and trace 

paste operations respectively.

- Menu Selections

File > Load Trace from Text File  
Brings up a file dialog so a disk file in either CSV or 

XY format can be input.

File > Save traces in Text Format
Opens a 'save as' dialog for each trace on the graph. 

Individual traces can be saved in either CSV (default) 

or XY format.

File > Print
Brings up a print dialog and produces a hard copy of the graph.

File > Close
Same as the close button on the window.
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--------------------------

Edit > Copy BMP
Puts a bitmap image of the user area onto the windows 

clipboard.

Edit > Paste Trace (TPASTE)
Loads and displays the current contents of the trace clipboard.

14SEP2012 31

Illustration 31: Edit Menu



ERGVIEW

--------------------------

Graph > Reset Graph Scaling
Sets both the x and y gains to one and adjusts the graph so 

that all traces are visible.

Graph > Align at  > Flashpoint

Adjusts the vertical offset of all traces so that they pass 

through 0.0uV at time 0.

Graph > Align at > Marker 1 time
Adjusts the vertical offset of all traces so that they pass 

through 0.0uV at the time of marker 1.

Graph > Separate Traces

This menu selection opens up a Trace Separation panel on which the user can enter values to 

be added to all the data points of any traces after the first one.  Scaling of traces two and on 

will be shifted by the amounts specified.  The traces are automatically aligned at flashpoint 

before any separation is applied unless alignment at marker1 is first selected.

Graph > Scale To Active Traces
Scaling of the comparison graph is done in general to make all parts of all traces visible. 

When traces are separated it is possible that parts of some traces will be shifted off the screen. 

Also, when filtering is in effect it was decided to maintain scaling using the non-filtered trace 

so that the trace being filtered doesn't appear to shift due to end data points being lost in the 

filtering process.  In either case, selecting this menu option will force the graph scaling to be 

such that all traces will be visible. 
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Graph > Show Graph Only
This selection expands the graph to include the whole 

client area of the window.

Graph > Show Gridlines
Draws light gray horizontal and vertical lines at 

each x and y marker position.

Graph > Show Average Trace
Adds an extra trace to the Comparison Graph that shows the average of all the current traces 

that do not have Use for scaling unchecked.

Graph > Show Marker 1
Graph > Show Marker 2

These selections default to being checked.  Unchecking them will hide the respective marker.

--------------------------

Pop-Up Menu

{right click} > Paste Trace
Adds the trace currently on the trace clipboard to the comparison graph.

{right click} > Set Marker 1
{right click} > Set Marker 2

Places a marker at the position of the windows cursor when the right click occurred.  Marker 

positions are also displayed in the bottom panel and, when both markers have been placed, the 

difference (delta time and delta volts) between the markers is shown.  The marker positions 

may be used to measure distances between graph points. 

{right click} > Add Annotation
Opens up an 'edit annotation' panel to allow for placing user text onto the graph (see 

Annotations section below).
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--------------------------

'Plot' (attributes) Pop-up Menu2

{right click} > {trace entry} > Plot > Show 
Toggles between displaying and hiding the selected trace.

{right click} > {trace entry} > Plot > Scale To
Determines whether this trace is used for scaling the overall graph when Graph > Reset is 

selected.  The default is for the graph to be scaled so that all points of all plots are within the 

graph boundary.  This selection toggles.

{right click} > {trace entry} > Plot > Fill > {line fill type}
Determines how the data points of a trace are filled in.  The None selection displays the points 

with no fill.  The Solid selection fills in between points with a straight line.  The Dash 

selections alternate between fill and no fill for the indicated number of data points (2, 5, or 

10).

{right click} > {trace entry} > Plot > Symbol > {symbol type}
Causes data points to be displayed as either a single pixel dot or as a plus sign.

{right click} > {trace entry} > Plot > Color > {color type}
Lets the user change the plot color.  Colors listed are red, black, green, violet, and blue.

{right click} > {trace entry} > Plot > Filter > 60 Hz
{right click} > {trace entry} > Plot > Filter > 50 Hz
{right click} > {trace entry} > Plot > Filter > Spikes
{right click} > {trace entry} > Plot > Filter > Low Pass
{right click} > {trace entry} > Plot > Filter > Set Low Pass Frequency

This menu mimics the filter menu for a thumbnail window.  Initially it will be set to 

2 The functions of the Plot and Copy to pop up menus are retained for compatibility.  Use of the Attributes panel for 

changing these items is encouraged.
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correspond to the settings of the source thumbnail but each setting can be changed 

here.  Modifications to the filter settings on the comparison graph effect ONLY the 

trace displayed on the graph.

--------------------------

'Copy to' Pop-up Menu

{right click} > {trace entry} > Copy to > Trace 
Clipboard

Copies the selected trace to the trace clipboard 

so it can be pasted into another comparison 
graph.

{right click} > {trace entry} > Copy to > 
Measurement Graph

Opens up a Measurement Graph using the 

selected plot.

{right click} > {trace entry} > Copy to > Osc Potentials Graph
Opens up an Oscillatory Potentials Graph using the selected plot.

{right click} > {trace entry} > Copy to > Comparison Graph
Opens a Comparison Graph displaying the selected plot.

{right click} > {trace entry} > Copy to > FFT Graph
Opens up an FFT Graph using the selected plot.

{right click} > {trace entry} > Copy to > Text File
Stores the data for the selected plot to a text file in “XY” format..
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- Drag and Drop operations

Instead of opening up a file dialog to add traces to the Comparison graph it is possible to drag and 

drop certain files from a windows file listing to the Comparison graph.  The file types available are 

test files (extension tst), xy files (extension xy), and csv files (extension csv).  

Drag and drop can be used as an alternative to using the File > Load XY data and File > Load CSV 

data.  
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- Moving data from Thumbnails to Comparison graphs

As an alternative to doing a trace copy from a thumbnail panel and a trace paste on a comparison 

graph, the mouse can be used to simulate a drag and drop operation.  Click on the graph portion of a 

thumbnail panel; this will create a small graph window at the cursor position.  Move the cursor over 

to the graph area of a comparison graph and click again.  A copy and paste operation will be 

performed automatically as illustrated by the sequence below.

----------------------------------

User has clicked on the thumbnail panel 

graph area.  The small window created will 

automatically follow the cursor.

Cursor is moved from the thumbnail over to the comparison graph.

After clicking on the comparison graph, the selected trace has been pasted.
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Illustration 41: Trace is ready to be 

pasted with a click of the mouse.
Illustration 40: Trace is being moved to the 

comparison graph.

Illustration 39: Trace has been copied 

as indicated by the small graph 

window.
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- Annotations

Text  annotations  may be  placed on a  comparison graph by right 

clicking on the graph and selecting “Add Annotation” from the pop-

up menu.  This will bring up a panel (see below) that will allow the 

user to enter a single line of text to be displayed on the graph.

Once an annotation is placed on the graph it may be modified by right clicking on it or moved 

by  pressing the left mouse button while the cursor is on the annotation and releasing the button 

when the cursor is in the new location for the text (dragging the text).  While the edit annotation 

panel is being displayed, text font and size may be adjusted by selecting the “Set Font” button. 

The “Cancel” button is provided in case the text, after modification, is not wanted.  Only the 

text characters will revert on cancel, not any new font or font size that was selected.
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A single annotation is limited to one line of 60 characters but any number of annotations may be 

added to a comparison graph.

Keep in mind that the position of the upper left corner of the rectangle defined by the annotation 

text is the reference point used when the graph is resized or shifted.
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Measurement Graph

When the Measurement Graph selection is made from a thumbnail pop-up menu ({rignt click} > 

Copy Test Data To > Measurement Graph), the ERG data for that thumbnail will be displayed as 

shown in the following figure.  The purpose of the Measurement graph is to present the user with 

values for a-wave and b-wave parameters and allow her to modify them if necessary.

The Measurement graph display of a standard ERG shows the peak amplitudes in microvolts of the 

first negative wave (a-wave) and the following positive wave (b-wave).  It also shows the implicit 

times in milliseconds.  Implicit times are measured from the time of the flash to the time of the 

respective (a or b-wave) peak.  The 'b/a ratio' is the absolute value of the b-wave peak voltage divided 

by the a-wave peak voltage.  

The position of the red dashed lines on the graph where the implicit time and amplitude are measured 

may be adjusted by the user.  To change the a-wave values, either 1) left click with the mouse inside 

the black circle for the a-wave and use the arrow keys to adjust the marker point; or 2) hold down the 
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control and shift keys and move the marker line using the arrow keys.  To change the b-wave values, 

either 1) left click with the mouse inside the black circle for the b-wave and use the arrow keys to 

adjust the marker point; or 2) hold the control key only down and again use the arrow keys.  When an 

implicit time value is changed this way (using the left or right arrow keys) the amplitude value will 

also change to follow the plot.  Amplitude values will change directly with the up/down arrow keys 

without the time position changing. 

A and b-wave values are measured relative to a baseline that is determined by examining the data 

points to the left of the flash time.  Baseline values may be manually adjusted using the flash point 

and right hand adjustment circles.  The flash point adjustment moves the baseline up and down and 

the right hand adjustment changes the baseline slope.

Changes to the a and b-wave values on a Measurement graph will be reflected both in the 

Measurement graph  parameters box and on the summary sheet  for the parent session window. 
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If the cursor is on the graph outside of either the a or b wave or baseline adjustment circles and the 

mouse is left clicked, a crosshair (X-Hair) will be displayed.  The X-Hair is for making additional 

time and amplitude measurements.  After the X-hair is created, it can be moved to a any location on 

the graph by using the arrow keys on the keyboard or by again left-clicking with the windows cursor 

at a new graph location.  The arrow keys will move the X-Hair by one pixel in the selected direction; 

the actual value change is dependent on the size of the graph on the screen.  The X-hair position is 

displayed below the ERG parameters box.

Two more position markers are available to the user by positioning the cursor at the desired marker 

position, right clicking, and selecting Set Marker 1 or Set Marker 2.   The positions of each marker 

and - if both are used - the voltage and time between them will be displayed below the ERG 

parameters box.   

14SEP2012 42

Illustration 47: Measurement graph showing markers and x-hair

a-wave position

b-wave position

x-hair

marker 1 marker 2

position of cursor on the graph distance of the cursor from the x-hair



ERGVIEW

To view and analyze other test waveforms with measurement graphs, go to the thumbnail window, 

right click, and again select Copy Test Data To > Measurement Graph.  All graph windows opened 

from a specific session will stay open until either they are individually closed or the session itself is 

closed.  

It should be noted that the default data plotted is the averaged waveform that results from the number 

of flashes made for that particular test (See the HMsERG User’s Manual, section 1,L).  By left 

clicking on View in the measurement graph menu bar, a drop-down menu gives the user options to 

show(or hide) the plot of the last ERG sample taken, and to show (or hide) the average ERG.  The 

Graph menu provides options to scale the graph to either the averaged (by default) waveform or to 

the last ERG sample taken.  Graph scaling is done by default from the averaged waveform so the last 

waveform may exceed the graph boundaries unless Graph>Scale to Last Sample is selected.

When flicker tests are stored, the HMsERG  program adds a flag to the test data to indicate a flicker 

waveform and the ERGVIEW  program provides a different set of ERG parameters.

The displayed waveform is the result of averaging the entire series of test flashes - for this instance - 
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in groups of four.   The data from the last set of four flashes can be viewed by using the View > Last 

Sample choice from the menu bar. 

Note: For cursor, x-hair and marker actions, the windows cursor must be on the graph part of the 

Measurement graph display.
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Special Keys

Ctrl + right or left arrow
Changes the b-wave implicit time.  The b-wave amplitude will change so as to follow the 

graph.

Ctrl + up or down arrow
Changes the b-wave amplitude without affecting the implicit time.

Ctrl + Shift + right or left arrow
Changes the a-wave implicit time.  The a-wave amplitude will change to remain on the graph.

Ctrl + Shift + up or down arrow
Changes the a-wave amplitude without affecting the implicit time.

Arrow Keys

When the measurement window has focus and an X-Hair has been placed the arrow keys 

(without any other keys being used) will move the current cursor position by one pixel in the 

indicated direction.

If an adjustment circle has been selected, turning the circle from black to green, the arrow 

keys will affect the corresponding parameter.  A and b-wave adjustments respond to all four 

direction arrows, the baseline adjustments respond only to the up and down arrows.

Left Click
Places an X-Hair on the graph indicating the current cursor position. The X-Hair position is 

displayed in the bottom panel.
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Menu Selections

File > Save Data as Text

Outputs the (average waveform) ERG data points in an x-y format so that they may be input 

to a spreadsheet program.

File > Print

Brings up a print dialog and produces a hard copy of the graph.

File > Close

Same as clicking the ‘close’ box (‘X’ at upper right of window).

--------------------------

Edit > Copy Window to Clipboard

Puts a bitmap image of the Measurement graph onto the windows clipboard.

Edit > Copy Average Trace

Puts the data from the average ERG waveform onto the trace clipboard.

Edit > Copy Last Trace

Puts the data from the last ERG sample onto the trace clipboard.
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--------------------------

Graph > Scale to Last Sample

It may happen that when View>Last Sample is selected, the last sample waveform is not 

completely contained on the display.  If this is the case, Graph>Scale to Last Sample will 

adjust the graph display so that it can be seen.

Graph > Recalculate a/b Parameters

This selection will reset all values to the values calculated by the computer.  This includes a 

and b-wave values along with the baseline intercept (value at the flashpoint).  If  Graph>Auto 

Baseline Slope to Zero is not selected the baseline slope will also be calculated.

Graph > Auto Baseline Slope to Zero

Default is on.  This will set the slope value of the baseline to zero without affecting the 

position of the baseline at the flash point.  This entry is to allow simulation of parameter 

values calculated by previous versions of ERGVIEW.
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--------------------------

View> Last Sample

Displays on the graph the last ERG sample taken.

View > Average Trace

Normally selected, this entry can be used to hide the average trace so that the last sample can 

be examined.  Even if not shown, the average trace (and not the last sample) is used for 

parameter calculation

View > Parameter Area

This selection is the inverse of the previous version's Graph>Show Graph Only menu entry. 

The parameter area is the area below the plot(s) containing the ERG parameters, Graph 

statistics, marker and x-hair value displays.

View > Adjustment Circles

Hides (or by default, shows) the four adjustment circles.

View > Baseline

Shows (default) or hides the baseline indicator.

View > X-Hair

Turns the x-hair visibility on and off.  The position of the x-hair is not changed and left 

clicking on the graph at another x-hair location will automatically turn the x-hair visibility on.
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--------------------------

{right click} > Set Marker 1

{right click} > Set Marker 2

Places a marker at the current cursor (‘X’) position.  Marker positions are also displayed in the 

bottom panel and, when both markers have been placed, the difference (delta time and delta 

volts) between the markers is shown.  The marker positions may be used to measure distances 

between graph points. 

{right click} > Copy Average Trace

This is the same as the Edit > Copy Average Trace selection in the menu bar.  The data for 

the average ERG waveform is placed on the trace clipboard.

--------------------------------

Notes:

When manually changing the a or b-wave implicit time and amplitude, make any changes in the time 

first, then if necessary, the amplitude.  Whenever a time change is made the corresponding amplitude 

will revert to it’s graph determined value.

It is possible to open multiple Measurement graph windows for the same thumbnail.  Each one will 

display the average ERG waveform that corresponds to the thumbnail ERG data and filtering in effect 

at the time that particular graph was opened.

Automatic a/b wave and baseline calculation is done using the latest thumbnail filtering selections. 

So, while all opened Measurement graphs will display the ERG as it was at the time the graph was 

opened, their parameter values will reflect those of the latest thumbnail state.  All parameters of all 

Measurement graphs (and values on the Summary panel) for a common thumbnail should be the 

same.
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FFT Graph

To view the Fast Fourier Transform of one of the ERGs, right click on a thumbnail and choose FFT.  

The FFT shows the frequency components that make up the ERG waveform.  The vertical axis 

measures the amplitude of the frequency in decibels below the maximum amplitude component.  The 

0Hz component is suppressed.   The horizontal axis measures the frequency in hertz.  The status bar 

displays the frequency and amplitude for where the windows cursor is currently located.
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FFT Menu Selections

File > Print
Brings up a print dialog and produces a hard copy of the graph.

--------------------------

Edit > Copy BMP
Puts a bitmap image of the graph on the windows clipboard.

--------------------------

Range >Toggle Freq Range 

The default FFT display goes to 400 Hz, if there are frequency components greater than -50 

DB past 400 Hz, toggling the range will display them.

Range > Linear Amplitude 

Makes the vertical scale linear instead of logarithmic.  The actual amplitude values in linear 

mode have no meaning except in their relation to other FFT components (so ignore the 

numbers).

{Right Click} > Inverse FFT
Displays an inverse FFT window.
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Illustration 53: FFT Graph of the same ERG with  
60Hz ripple filtered out
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Inverse FFT graph

An additional feature is offered where the user may display the “Inverse FFT” graph by right clicking 

on an FFT graph, then choosing (pop-up menu)  Inverse FFT.  This initially shows the inverse FFT 

of all of the FFT values obtained (which should give the original ERG waveform back).  Slider 

controls on the inverse FFT graph allow frequency components to be removed and the resulting 

waveform displayed.

 

The inverse FFT is provided as another way to filter the ERG waveform, similar to the oscillatory 

potential graph.  It displays the real part of the inverse FFT including only the indicated frequency 

(Min Freq..Max Freq) components.

The inverse FFT graph initially shows the inverse of all significant FFT coefficients obtained, so 

what is seen when the inverse FFT is opened is the original ERG waveform.  The slider controls may 

be adjusted to eliminate desired frequency components.

The parent FFT graph will indicate what components are being used by displaying removed 
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components in red.  

Inverse FFT Menu Selections

File > Print

Brings up a print dialog and produces a hard copy of the graph.

--------------------------

Edit > Copy BMP

Puts a bitmap image of the graph on the windows clipboard.

Edit > Copy Trace

Copies the plot data to the trace clipboard.

--------------------------
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Oscillatory Potentials Graph

To view the Oscillatory Potentials of an ERG right click on the thumbnail of the ERG and choose 

Copy To > Osc Potentials Graph .  The following oscillatory potential graph shows the ERG 

data filtered with a frequency window running from 100 to 300 Hz (which is the default frequency 

range).

The oscillatory potential graph is a display of the ERG waveform which has been processed through a 

band-pass filter.  The vertical axis shows the amplitude of the oscillatory potentials in microvolts and 

the horizontal axis shows the time after the stimulation flash. 

Slider controls are provided to allow the user to manipulate the viewing window, change the center 

position of the display, change the window magnification as well as the upper and lower cutoff 

frequencies. 
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Menu Reference

File > Print
Brings up a print dialog and produces a hard copy of the graph.

--------------------------

Edit > Copy BMP
Puts a bitmap image on the windows clipboard.

Edit > Copy Trace
Puts an image of the displayed trace on the trace clipboard.

--------------------------

{right click} > Copy to Trace Clipboard

Places the OP plot on the trace clipboard.

{right click} > Copy to Measurement Graph
Opens a measurement graph displaying the filtered waveform.  This is intended to be used to 

determine a and b-wave parameters from a filtered waveform (with the minimum frequency 

set to zero).
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Test Locator panel

The Test Locator panel is used to search through the file structure on the PC and select those test 

files that match a certain search criteria.  Searching is done starting at a selected root folder and 

by default includes all sub folders of that selected folder.

Searching can be done using a Test ID, a patient number, an OD or OS selection, or a User ID. 

More than one search item in which case tests must match all given search items.  The Test ID 

and User ID items may hold a search pattern so that matches to only a part of these items may 

be used.

Search criteria matching is not case sensitive. 
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General Procedure for Locating Tests

1) Set the test file root directory path. 

See Selecting a new root test directory below. 

Once a directory path has been chosen, that 

path will continue to be used for all following 

searches.

 

2) Set the search criteria.

The test id, patient number, OD/OS , and 

User ID entries are used for finding tests.  See 

The Format of Search Criteria entries below.

3) Initiate the search.

Click the Find TESTS button in the search 

criteria group.

The ERGs found are listed in the Test list.  A thumbnail 

presentation of the currently selected (highlighted) ERG 

is shown and, by right clicking on the thumbnail, all of 

the pop-up menu selections that are available on a 

thumbnail are available here just as if this thumbnail 

were part of a session window. 

Unneeded tests may be pruned from the test list by selecting them and left clicking the Remove 
button.  This does not affect the test file on the PC.

What The Search Control group entries correspond to

Test ID, patient number, and OD/OS are entered on the HMsERG unit and their value is stored as part 

of each test file.

The User ID for a test is entered in the State Information panel that is opened by right clicking on a 

thumbnail and choosing Test source info.
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Selecting a new root test directory

Selecting the Select > New Test Directory menu selection will open a 

directory selection  window.   The  one shown to  the  right  is  for  a 

computer that has never set the root test directory before.  After the 

first time a root test directory has been selected, the panel will open 

displaying the current selection.  The letters in the curly braces are 'V' 

for a volume and 'D' for a directory.

Left click on a directory or volume to select it and then right click to open a pop-up menu.  For  

our use,  only the 'Show Subdirectories'  selection will  be used.   Left  clicking on the Show 

Subdirectories selection will open up a list of folders under the directory or volume chosen. 

Again, cursor at the item to open, left click, right click, cursor on Show Subdirectories, left 

click.

This  process  is  repeated  until  the 

desired  root  directory  is  found  and 

highlighted by left clicking on it.  The 

path to that directory will be displayed 

in the edit panel just below the title bar.
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selection window.

Illustration 61: Final directory 

selection.Illustration 62: First 

subdirectory display.
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The Format of Search Criteria entries

Search criteria may be entered into the fields of the search criteria group so that ERGVIEW can find 

the desired files and/or patient data from the search path root directory.

Entries left blank are not used for ERG selection.  Otherwise, entering a search pattern in the 

appropriate field entries will provide patterns to guide a search of the ERG files on disk.  For ERG 

test searching, the Test Id, Patient Number, User Id, and OD/OS fields are used.  For Patient record 

retrieval, the Test Id, Patient Number, Patient Id, and Owner Id fields are examined.  Records or tests 

selected will be those that match all used search criteria fields.  For an ERG to be selected, all of the 

search criteria field entries must be satisfied simultaneously.  

Patterns for search control group entries.

Alphanumeric fields are matched without regard to case.  Leading and trailing blanks are not included 

in comparisons.

- Patient number :

This is the patient number as entered on the HMsERG and as recorded in the test file name 

(Pnn).

A valid patient number is an integer from 1 to 99.  If one of these numbers is entered, only 

records/tests with that patient number will be found.  If this field is blank, or zero, it will not 

be used for record selection.

- OD/OS :

Either ‘OD’, ‘OS’, or blank is acceptable.

- Test Id and User Id:

These are alphanumeric fields and, for a given entry, the patterns specified guide the search of that 

field for a match.  Asterisks (*) and question marks (?) are wild cards; the first matching any string up 

to the character following it, the second matching any single character. 

Pattern variations may be:

1) a string of characters without any asterisks (*) or question marks (?). This pattern must be 

matched exactly by the corresponding test file or patient record field.

2) a string of characters, some of which are replaced with question marks.  All non-question 

mark characters must be matched exactly.  In the places where there is a question mark, there 
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may be any character (including a space).

3) an asterisk followed by a character string.  A match is obtained if a record string of n 

characters matches the last n characters of the pattern.  Any partial match that is not an exact 

match is considered not to be a match.

4) a character string followed by an asterisk.  In this case, the character string must be a prefix 

string to the record entry.

5) an asterisk followed by a character string followed by another asterisk.  This pattern will 

match any record where the character string exists at any point in the field.  A non-exact 

partial match is a fail.

For 3), 4), and 5) the character string may also contain question marks.

If a question mark or asterisk is part of a character string to be matched, enclose the character string 

in double quotes (“).

Examples for test id and user id searches:

‘TEST’ Finds tests/records with the test id exactly equal to ‘TEST’

‘TEST*’ Finds tests/records starting with the letters ‘TEST’ and having any characters 

following.

‘*TEST*’ Finds all tests/records that have the string ‘TEST’ in them anywhere.

‘*T*’ Finds all tests/records with a ‘T’ in them.

‘TEST?’         Finds all tests/records with a 5 character field starting with ‘TEST’.

‘?TEST’ Finds all tests/records with a 5 character field ending with ‘TEST’.
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Test Locator Control Reference

--------------------------

Test Locator Controls

Find TESTS (button)

Uses the Test Id, patient number, User Id and OD/ID fields to find test files under the 

test directory path.

Search Subdirectories (check box)

Allows the searching of sub directories of the root directory folder.

- Test list:

Note : these push buttons are hidden when there is no entry selected in the list they refer to.

Remove from List (button)

Removes the currently selected test list entry from the test list.  It is not removed from 

the PC.  

List –> Session (button)

Creates a session window containing all the tests currently listed in the test list. 

Session windows created in this way will remain open even after the test locator 

window is closed.

--------------------------

Select Menu

Select > Test Directory

Allows for selection of a folder containing the test records that are to be searched for listing in 

the test list.
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GLOSSARY

What follows are definitions of terms used in this manual.  They are to be interpreted within the 

context of the ERGVIEW  program. 

average waveform
Each ERG test data set contains the data points for two waveforms: the average of all data and 

the last data points taken. The most generally useful one is the average of all the data taken for 

that ERG; although, for single-flash tests the average waveform and the last waveform will be 

identical. 

a-wave
ERGVIEW  locates the a-wave by first finding the b-wave and then backing up to the most 

negative point of the ERG waveform.

b-wave
ERGVIEW  finds the location of the b-wave by finding the most positive portion of the ERG.

default path
Also called default file path.  The file path remembered by the ERGVIEW program and used 

to find an initial instance of a file.  The program has default paths for sessions, special 

sessions, xy, and csv files.  Default file paths are updated whenever a new path is selected for 

opening or saving.

directory
A container for files or other directories on a computer.  Also called a folder.

eti
The elapsed time indication (eti) entries are time values measured from the start of the test or 

session till the point of ERG data storage.  The eti is reset to zero at the start of either a session 

or a test that is not part of a session.  Elapsed time is shown on Summary windows.

folder
A container for files or other folders on a computer.  Also called a directory.

ERGVIEW

The PC program for viewing ERG waveforms recorded by the HMsERG.
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HMsERG or HMsERG unit

This is the device used to record ERG waveforms. 

last waveform
Each ERG test data set contains the data points for two waveforms: the average of all data and 

the last data points taken. The most generally useful one is the average of all the data taken for 

that ERG; although, for single-flash tests the average waveform and the last waveform will be 

identical. 

left click
With the windows cursor positioned in the appropriate area depress and release the left mouse 

button.  Selection of an item by mouse is generally a matter of left clicking on that item.

right click
With the windows cursor positioned in the appropriate area depress and release the right 

mouse button.

sample (or data sample)
A single capture of data when running a test on the HMsERG unit.  Each ERG test is 

comprised of one or more samples.  Normally only the last sample taken and the average of all 

samples is available in a test (tst) file.  If 'Save all Samples' is set to yes on the unit then any 

other samples takes will be stored in sample files with the extension 'spl'.

session window
The session window contains a group of ERG tests that the user has determined are related in 

some way.  The default grouping is to all tests that have the same patient and sequence 

number as the initial test file selected.  ERG tests may be added or removed from session 

windows at the user’s discretion.  The term “session” used here is synonymous with “session 

window”; references to a “session” on the HMsERG will be so indicated to avoid confusion. 

special session
A session composed of tests selected by the user and given a special session name.  Special 

sessions can be opened just like regular sessions and have a default path independent of the 

one for regular sessions.

test or ERG record
The data collected when a test is run on the HMsERG.  This includes not only the ERG data 

but information about the test parameters, test id, patient number, a flicker flag, OD/OS, etc.

test id 

The 10 digit field entered into the Test id panel when preparing the HMsERG for testing.
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test waveform or ERG or ERG waveform
The data collected for a test.  What is plotted on the measurement or comparison graph.

text file format
Text files (as in “save as text”) are stored with tab characters separating fields and carriage 

returns terminating each line.  The “XY” data format is in text file format.

thumbnail
A representation for an ERG test showing the average waveform and descriptive information 

for that specific test.  Thumbnails are used in session windows and test locator windows. 

There is a one to one correspondence between ERG tests and thumbnails.

trace
A “trace” refers to the information necessary to display data points on a graph.  It includes not 

just the data points but information about color, symbols, line type, etc.  Traces can be copied 

from various places in ERGVIEW onto a comparison graph.   You can copy traces from 

thumbnails, measurement graphs, oscillatory graphs, and comparison graphs. 

User ID
This is a user determined field of the Test Source Info window.  It is specific to the ERG of a 

thumbnail panel and can be used by the Test Locator window for finding ERG's.

XY data format
A text format for recording plot data onto disk.  ERGVIEW stores one data point per line as ‘x-

value’ <tab> ‘y-value’<return>.

window
My definition of a 'window' is essentially that used by Microsoft; a screen entity that can be 

moved, resized, minimized, etc. as a whole.  This term is included here because the term 

'panel' has also been used in the same context as window.  The term panel will be used to 

specify a section of a window or a 'child window' of a window.   A graph (as in measurement 

graph) is also a window.
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APPENDIX A

Getting Test Files from HMsERG to ERGVIEW

Test data files are stored on a compact flash card by the HMsERG unit.  They can be accessed by 

ERGVIEW  in one of two ways.  By reading tests from the CF card using either a card reader or a 

USB connection. 

If  a  compact  flash card  reader  is  available  the  CF card can be  removed from the unit,  and 

installed in the reader, and accessed directly by ERGVIEW .  The flash card will show up on 

the  PC as  just  another  storage device.   This  storage device can be accessed by  ERGVIEW. 

Alternatively, the test files can be copied to a folder on the PC and accessed by ERGVIEW  from 

there.

The individual test files stored on the CF are located in directories that were given names that 

were derived from the current test date and from the id of the compact flash card. 

ERGVIEW  requires that the host PC have a software application named Microsoft ActiveSync. 

This is a program that is used with Windows CE based PDA’s and other Mobile devices.  Since the 

Unit’s operating system is based on Windows CE, ActiveSync can be used to copy the files 

from the Unit to a PC using a USB connection. 
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1.  Start the HMsERG  program.

2.  Connect the USB cable between the PC and the HMsERG unit.

3.  Observe “WOULD YOU LIKE TO SET UP A PARTNERSHIP?”

Mark the radio button indicating “No”. click NEXT.

4.  The panel MICROSOFT ACTIVESYNC is displayed showing “CONNECTED”.

5.  A green double-arrow circle shows up in the task bar.

You can now use either ERGVIEW or the file 

icon ‘Mobile Device’ to access files from the 

HMsERG unit 
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a) Transferring files from the HMsERG to the PC using ‘Mobile Device’.

Once a connection is made, on the PC go to My Computer or some other file viewer and look 

for the files on your Unit by clicking on the Mobile Device icon.  This is much like looking 

for files on a CD-ROM or floppy drive.  To see the files on the CF card, click on Storage 

Card.  You will see test files in directories named by the date of the test, just as when using a 

card reader.  These files can be copied to your desktop or any other directory on your PC. 

b) Opening files from the HMsERG using ERGVIEW.

Start ERGVIEW (if it is not already running) and select (Unit)View Session..  Once a 

connection is established, the HMsERG program is no longer needed; if the unit times out it 

will not affect file access by ERGVIEW.

The USB cable should be disconnected before rebooting the HMsERG program, it can be reconnected 

after the reboot; this will prevent an ‘unknown device’ error message on the PC. 
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APPENDIX B

FILE TYPES USED BY ERGVIEW

--- HMsERG test files (extension 'tst')

These are files produced by the HMERG program containing the last data sample taken, an 

average of all data samples taken, and identifying information about the test.

--- HMsERG test sample files (extension 'spl')

These are individual data samples saved by the HMsERG when 'Save all Samples' is turned on in 

the System Parameters panel of the HMsERG.

--- Test 'state' files (extension 'st_')

Information that shows up on the Test Source Info panel is stored here.   

--- Special session files (extension 's_f')

These are files created by ERGVIEW when the 'File>Save as a special session' menu of the 

Session panel is used.  These files contain information to reconstruct the session window they were 

created from.

--- Text files in <xvalue><tab><y value> format (extension 'xy')

These files can be used to transfer graphs (that is, the data points used) between ERGVIEW and a 

spreadsheet program.

--- Text files in <xvalue>,<y value> format (extension 'csv')

These files can be used to transfer graphs (that is, the data points used) between ERGVIEW and a 

spreadsheet program.

--- Text x-y file extra information (extension 'cv_')

Information pertaining to the corresponding text x-y file is stored.  Currently graph x and y units 

are the only entries.
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APPENDIX C

WORKING WITH DATA SAMPLES

Most tests that the HMsERG executes take multiple data samples and averages them to produce the 

resultant ERG  test file seen by the user.  Starting with S/W VERSION 3.225 the HMsERG unit can 

be instructed to save all samples taken and these samples can be examined by ERGVIEW versions 

4.000 and above.

- On the Unit:

To save all samples, go to the System Parameters panel on the unit 

and select "Save all Samples".  Set the parameter value to 1 (yes) to 

save samples and 0 (no) to continue operation as before.

When samples are being saved, all but the last data sample taken 

will be stored on the compact flash card in files named after the test 

file they are a part of with the addition of a "-NN" where NN is a 

sample number including any leading zero and an extension 'spl'. 

The final sample taken was always stored in the test (tst) file

3

 and 

this has not changed.

3 The last sample is accessible using the Measurement graph as before.
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- Using ERGVIEW to work with samples:

Individual  data  samples  can  be  accessed  by 

Thumbnail panels and Comparison graphs.

When ERGVIEW finds sample files associated 

with an ERG test file it places the number of 

samples  found to  the  right  of  the  "Filtering:" 

label enclosed in parenthesis.

The graphical display on the thumbnail defaults 

to  the  average  of  all  samples  taken  whether 

samples were recorded or not.  If samples were 

recorded they can individually be selected for inclusion in the average by opening a Sample 

Selection window and adding or removing check marks on individual samples.
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Right click on the thumbnail and select Filter > Show Sample Selection Window (illustration above). 

The Sample Selection window is shown below.

Once the Sample Selection window is open, click on the check boxes to toggle the check marks.  The 

graph in the thumbnail will be modified each time there is a change on the Sample Selection window. 

Sample selections from thumbnails will be saved in the state file for the thumbnail so whatever 

selections are made by the user will be preserved the next time the thumbnail is opened.

Any item chosen on the Copy Test Data To > thumbnail pop-up will incorporate the current sample 

selections.
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APPENDIX D

Program Changes

Version 4.380

14SEP2012 -Corrected a labeling problem in that, when a file name contained a test 

id the name in comparison graphs always said it was channel 'B'.

-Added the capability to insert a trace indicating the average of all the 

other traces on a comparison graph.

- Moved the text 'x-y' file type selection (csv, xy) from program menus to 

the file selection dialog.

Version 4.365

20JUN2012 -Added a visible baseline and the ability to manually adjust it to the 

Measurement graph.

-Added a View menu to the Measurement graph to allow a selection of 

items to be shown or hidden on the screen and on the printout.

03FEB2012 -Rearranged comparison graph menus.

Version 4.135

31JAN2012 Summary panel now updates when a/b wave values change due to a 

sample selection change.

Version 4.130

02Jan2012 Modified placement of samples window.

19Dec2011 Reversed the a-wave/b-wave display lines on thumbnails so that a and 

b wave values are displayed in the same sequence as on measurement 

graphs.

19Dec2011 Changed thumbnail, comparison,  and measurement graphs so that 
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they keep the waveform after a change in filtering in the visible area. 

Removed automatic 'align at flashpoint' from comparison graphs.

19Dec2011 Corrected flashpoint calculation that was causing bad a-wave values to 

be reported.

Version 4.115
- Added the ability to modify the low pass frequency all thumbnails of a session at 

once.

- Added trace copy from a thumbnail and paste to a comparison graph by using the 

cursor in a drag and drop fashion.

Version 4.055
- Added capability to examine individual test samples and print out their graphs.

- Added a log intensity column to the Summary window.

- Added Optical filtering information to Thumbnail panels.

Version 4.000
- Changed opening window to a normal window that allows drag and drop operations.

- Added attributes panel to the comparison graph.

- Removed the Patient ID information from the Test Locator window.

Version 3.225
- Low filtering frequency was not retained unless a filtering mode was changed.

Version 3.204
- Session panel and printouts were changed to show waveform a and b wave values 

along with the waveform peak to peak value.

Version 3.200
- Sessions can be customized through the thumbnail cut/copy/paste operations and 

saved as a group.

Version 3.111
- A and b-wave indicator circles were added to the measurement graph to allow 

clicking w/in a circle and using the arrow keys to adjust the value.

- A ‘Trace Separation’ entry was added to the measurement graph ‘Graph’ menu.

Version 3.107
- The user may enter notes and individual test identification strings for test files stored 

on the PC.  This test identification may be used to search for test files using the test 
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locator panel.

- Restored the filtering option to the thumbnail and, separately, to the session window.

Changes from version 2.5.7 to version 3.104.

- The Database window has been renamed Test Locator window.

- Test files can now be dropped from a windows explorer window onto a comparison 

graph.

- User annotations can be added to Comparison graphs.

- Test times now come from information in the test files instead of from the operating 

system  file time.

- Multiple traces can be saved in one operation from Comparison graphs.

- Moved filtering from thumbnail to Comparison graph.

- Multiple individual files may be selected for a Session window.

- The flashpoint voltage calculation for calculating the a and b-wave amplitudes was 

changed from using the data point at time zero to using the intersection of the 

regression line for the pre-flash values.
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APPENDIX E

LIMITED WARRANTY

OCUSCIENCE LLC, a subsidiary of Xenotec Inc., a Missouri corporation ("Seller") warrants to 

the original purchaser of this product that this product will be free of defects in materials and 

workmanship for a period of one (1) year from the original date of purchase. If the product 

should become defective within the specified warranty period, Seller will repair or replace, at its 

option,  any  parts  that  appear,  to  its  satisfaction,  to  have  been  defective  in  material  or 

workmanship. Seller will refund to the purchaser the purchase price if the defect in the product 

is one covered by this warranty, and Seller is unable, by repair or replacement, to make the 

product perform the work for which it is designed. This warranty does not obligate Seller to 

bear  any transportation,  removal,  or  installation  charges  in  connection  with  the  inspection, 

repair,  or  replacement  of  defective  parts.  The  limited  warranty  contained  herein  is  the 

purchaser's exclusive remedy. 

To obtain warranty service,  the purchaser must deliver the product or the defective parts to 

Seller's  service  facility  or  other  point  designated  by  Seller.  Shipping  expenses  are  the 

purchaser's  responsibility.  The  purchaser  should  contact  Seller  at  the  following  address  for 

instructions on where to obtain warranty service: 

Ocuscience LLC.

8609 Jarboe St.

Kansas City, MO 64114

This warranty does not cover any defects or costs caused by: (1) modification, alteration, repair,  

or service of this product by anyone other than Seller; (2) physical abuse to, or misuse of, the 

product or operation thereof in a manner contrary to the accompanying instructions; (3) any use 

of the product other than that for which it was intended; or (4) shipment of the product to Seller  

for service. 

This  warranty does  not  apply to  component  parts  of  this  product  that  were  not  originally 
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manufactured by Seller; such items are sold to purchaser on an "AS IS" basis. This warranty 

also excludes all costs arising from routine maintenance, including the replacement of any parts 

required  by  such  maintenance.  Seller  reserves  the  right  to  modify,  alter,  or  improve  this 

product, or parts thereof, at any time without incurring an obligation to modify, alter, improve, 

or replace any product, or parts thereof, previously sold. 
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